Which browsers are supported for assessment creation?

If you're encountering difficulties creating your assessment, you might want to be sure you're using a supported browser.

Generally speaking, TestGorilla supports all major browsers in their most up to date versions. Most specifically, we support the following browsers by system type:

System

Browsers and Versions

Windows 10
  • Chrome: Version 80 or more recent. Chrome typically updates itself automatically (you have to actively choose to turn off automatic updates) so usually you'll have the latest version, but any recent version should work.
  • Firefox: Any version after version 68.
  • Edge: Any version after 18 should work
  • Internet Explorer: Because Microsoft stopped supporting IE when they released Edge, we do not support IE
MacOS
Mojave, Catalina, or Big Sur
  • Chrome: Version 80 or more recent. Chrome typically updates itself automatically (you have to actively choose to turn off automatic updates) so usually you'll have the latest version, but any recent version should work.
  • Firefox: Any version after version 68.
  • Safari: Any version later than 10.14
 
Though the system may still work in some capacity in other, less known browsers, we are unable to provide support for those browsers if you encounter issues.